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SUMMARY  

The ôAdvanced Formsõ module makes it possible to create forms for surveys, registrations, 

inquiries, etc. The focal point of the forms module is maximum flexibility with minimal 

settings. For editors i t should be easy to, for example, compose surveys. Developers with 

higher authorizations, are able to add more complex constructs by e.g. using XSL.  

Forms consist of steps that should be taken in a specific order. This order can depend on the 

values entere d. The input can be validated in various ways. Also lots of options are available 

to handle forms: sending data by e -mail and/or saving data in a database, form -specific error 

handling, ôThank Youõ pages, etc. Forms can also be used for specific types of integration 

such as connections with authorization or payment systems and transactions through SOAP.  

 

The latest version of this document is available at:  

http://www.gxdeveloperweb.com/documentatio n/  

 

 

PREREQUISITES  

Content Management  

¶ Content Management ð Basic 

¶ Content Management - Advanced 

 

 

RELATED TOPICS  

Interaction Management  

¶ E-cards 

¶ E-mail forms  

 

Connectivity Management  

¶ Verseon Connector  

¶ Queries  

 

Workflow & Authorization Management  

¶ Personaliza tion Rules Toolkit  

 

 

http://www.gxdeveloperweb.com/documentation/
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1  INTRODUCTION  

Forms can be used to handle interaction with website visitors. In general, a form consists of steps 

the visitor can follow to enter data. Based on the data entered, one or more actions are taken, 

for  example, sending an email. Examples of forms are e -card forms and booking forms.  

 

Example of a form:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A form is based on a form model. A form model consists of steps which, together, create a flow. 

Such a flow is defined by means of validators, handlers, and routers. For each form, a report can 

be generated.  

 

Form models are defined in the Maintain > Forms > Models  menu. Forms can be placed on a 

page through the Insert > User interaction > Form  menu. E-mail forms , e-card forms , 

and Verseon forms can also be defined. Explanation of these forms falls beyond the scope of this 

document.  
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The forms module is based on the following principles:  

¶ Form 

A form is always based on a form model . Each form model can have several forms. A 

form is pl aced on a page. It can be verified if a form has been filled out or not and a 

report  can be generated.  

¶ Form part > Step > Flow > Form model  

A form model has a flow . A flow is constructed from steps. A step has one or several 

form parts  (text, list, button,  etc.). The display and appearance can be determined on 

the step level and on the form parts level.  

¶ Appearance  

The different form parts of a step have the same look and feel as the content elements 

on a page. The form parts can be expanded, collapsed, moved,  and deleted. The steps of 

a flow can be previewed within the forms functionality.  

¶ Placing a form  

Once a form model has been developed and has been used to create a form, this form 

can be placed on the website. In the GX WebManagerõs edit environment, it  can be 

determined whether the various steps of that form should be on one page or split over 

several pages. A step can be shown on only one page. 
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2  DEFINING OPTIONS  

Before a form model can be developed, a number of options have to be defined and set:  

¶ Categories to be able to divide the form models in groups.  

¶ Predefined lists  that can be used by the list form parts.  

¶ Connections with internal and/or external resources.  

¶ Defining handler, router, and validator rules  to be used in the flow definition and on the  

form parts in the steps of a form model.  

¶ Handler definitions  to be used in the flow definition of a form model.  

 

A lot of rules and handler definitions are already included in GX  WebManager. It is, however, also 

possible to adapt these rules and handler d efinitions and create new ones.  

2.1  Categor ies  

Create categories to divide the form models in groups. This is not a required step but it does 

make it easier to manage form models when the list of forms is large.  

 

Ý Select the [Categories]  tab from the Maintain >  Forms > Options  menu. 

 

Ý Create a category by selecting ôNew categoryõ next to ôSelectõ. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ý Enter the name of the category and click [Apply] . The category is now available on 

Form models. 

 

Note : It is also possible to change and delete categorie s. 
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2.2  Predefined l ists  

If a form part of the ôListõ type is placed on a form step, the associated list can be defined on the 

spot or a predefined list can be used. These predefined lists can be created on the [Options]  

tab. This is not a required step, but it is recommended if lists have to be able to be re -used; it is 

also a good way of maintaining lists centrally.  

 

Predefined lists can be compiled in two different ways:  

¶ By entering the list elements one by one.  

¶ By defining a query on a database.  

2.2.1  Entering l ist elements manually  

Ý Select the [Predefined lists] tab from the Maintain > Forms > Options  

menu. 

 

Ý Create a new predefined list by selecting ôNew listõ next to ôSelectõ, enter a name for 

the predefined list next to 'Description', and click [Apply] :  
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Ý Enter a value under ôAddõ and click [Apply] :  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The next value can now be entered .  

 

Ý Enter all list values. The order of the values here is also the order that the list elements 

are shown at the website environment :  
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Ý In the column next to the values, a numeric value has to be entered because the list 

elements will be written to a database in which the numeric  values fill an indexing 

column: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note : If no numerical values are entered, the values enter ed by the user will not be able 

to be reused, for example, in a confirmation e-mail.  

 

Ý The default value(s) can be selected in the ôCheckedõ column: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The predefined list can now be selected in f orm model s.  

 

Note : It is also possible to change  and delete list elements and lists.  
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2.2.2  Generating  list elements using a query  

Ý Select the [Predefined lists]  tab from the Maintain > Forms > O ptions  menu. 

 

Ý Select ôNew queryõ next to ôSelectõ to create a new predefined list that is based on a 

query:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ý Enter a name the predefined list, select the database (a connection with that database 

should already exist), enter the query, and click [Apply] :  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Predefined lists based on queries require two columns in the SELECT clause: 

o First, a numerical column (with alias ôidõ) of which the value will be forwarded 

when the form is sent.  

o Second, the column (with alias ônameõ) that contains the values to be shown on 

the page.  

 

The predefined list can now be selected from list elements on the steps o f form models.  
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2.3  R esource s  

A resource is a table in a database that can be written to and/or read from. For example, if a 

visitor places an internet order from the same company for the second time, he or she does not 

want to enter all the contact/payment data again. After it has been entered the first time, the 

customer data should be saved in a table in a database and be recalled from that same table 

when the visitor returns.  

 

Ý Select the [Resources]  tab from the Maintain > Forms > Options  menu. 

 

Ý Create a new resource by selecting ôNew resourceõ next to ôSelectõ. 

 

Ý Enter the new resourceõs data: 
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The fields on this screen have the following meanings:  

Field  Description  

Name 

 

Name of the resource as it should be listed in 

GX WebManager. 

Value 

 

Internal name of the resource. Fill this field if something 

should be done in the code.  

Tag name 

 

The name of the tag under which the fields are placed in 

the session (for example, 

/root/system/person/country ).  

This is used for prefilling.  

XSL for prefilling the form fields  

 

If more transformations are needed on the fields before 

prefilling, it can be programmed here in XSL (for example, 

changing date format or capitalization).  

Table name 

 

Name of the database table to be written to or read from.  

Database 

 

Name of the database where this table is located (a 

connection with this database should already exist).  

Entry - Name 

 

Field name as displayed to the user.  

Entry - Value 

 

Internal name of the field.  

Entry ð Field name 

 

Column in the database this field is associated with.  

Entry ð Primary key 

 

Whether the column is a primary key column in the 

database. 

Entry ð Auto increment  

 

Whether this column should be filled automatically by 

means of a sequence. 

Entry ð Foreign key 

 

Whether the column i s a foreign key column in the 

database. 

Entry ð Allow null  

 

Whether this column is optional or required.  

Entry - Delete 

 

Delete this entry by checking the check box and saving the 

resource. 

Entry ð [New entry] button  

 

To manually add a new entry.  

Entry  ð [New resource entry] button  

 

Clicking this button automatically retrieves all columns 

from the relevant table and displays them as a list of 

entries.  
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2.4  Rules  

For setting up form models, four types of rules can be defined on the [Rules]  tab from the 

Mai ntain  > Forms > Options  menu: 

¶ Form handlers 

¶ Form routers 

¶ Form validators  

¶ Form parts validators  

 

These rules can be used for setting up form models.  

 

By selecting one of the four rules types ( see A in the image below ), only the rules of that type are 

displayed in the pull -down menu (see B). By selecting ôFilter by labelõ (see A), all rules of any 

type are displayed in the pull -down menu (see B):  

 

Example: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The following subsections elaborate on  the four types of rules  and explain how rules can be 

created and deleted.   
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2.4.1  Handler  

For rules of the ôHandlerõ type, form handlers are defined that can later be used in the flow of 

form models.  

 

Select menu Maintain > Forms > Options  > [Rules]  tab > Select type = ôAfhandelingõ. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



CONNECTIVITY MANAGEMENT 

Advanced Forms   

 

 
   E  info@gx.nl      WWW.GX.NL     18/ 83  

 

The fields on this screen have the following meanings:  

Field  Description  

Basic - Name 

 

Name of the handler as it should be listed in GX  WebManager. 

Basic - Description  

 

Handler description. This is displayed on the form modelõs flow if 

this rule is selected.  

Parameters can be used here to insert fields and, for example, to 

pass on the sequence of the fields to the user (using the 

description of the parameter).  

Example: 

 

 

 

 

 

 

 

 

 

 

 

 

 

Clicking the ôWebManagerõ link produces the following pop-up 

window:  

 

 

 

 

 

 

 

 

 

 

Basic - Available  

 

Whether this handler may be used in the form models.  

Basic - Label 

 

Rule type (ôHandlerõ, ôForm validatorõ, ôRouterõ, or ôValidatorõ). 

Basic ð Java handler class 

 

Java class called by this handler.  

Basic ð Additional 

identifier  

Internal GX WebManagerõs name for the rule. Fill this field if 

something should be done in the code.  
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Basic - Precondition  

 

Condition that has to be met before the handler is started.  

Example: 

count(/handler/flow/formelement/error[@code  = 

'not_found']) &gt; 0  

Basic - Resource 

 

This field will be removed.  

Basic ð Connection name 

 

Select the name of the relevant resource, as defined on the 

[Resources] tab. This connection name is used by handlers that 

execute a query and can only be sele cted if the handler needs a 

connection name.  

Parameters and messages should be created and set if GX WebManager requests it. 

GX WebManager detects whether parameters and/or messages are missing, and reports it.  

The difference between a ôParameterõ, a ôDedicated parameterõ, and a ôMessageõ is the fact 

that the value of a ôDedicated parameterõ is entered with the relevant Rule (for example, by 

the application manager), and the value of a ôParameterõ and a ôMessageõ is entered on the 

form model or the content  element (for example, by a functionality manager).  

In this location, warnings and error messages that pertain to the parameters, dedicated 

parameters, and messages, appear in red.  

Parameter - 

 

The parameterõs sequence when the parameterõs values are 

entered on the form model.  

Parameter - Description  

 

Text that appears as the label of the parameter when the value is 

entered, if @parametercode@ is used in the handler description.  

Parameter ð Code 

 

Name of the parameter, as programmed in the Java code. Thi s 

code cannot be modified.  

Parameter - Type 

 

Parameter type:  

¶ Text (plain text can be entered)  

¶ Form part (a selection from form parts can be made)  

¶ Form part value (a selection from form part values can be 

made) 

¶ Number (a number can be entered)  

¶ Page (a page selection can be made)  

¶ Form step (a selection from form steps can be made)  

¶ Entered value (a selection from values can be made)  

Parameter - Multiple  

 

Whether multiple values can be entered for this parameter.  

Parameter - Decentral  

 

Whether this parameter  is defined in the form model (=  central) or 

in the content element on the page (=  decentral).  

Parameter - Delete 

 

Delete this parameter by checking the check box and saving the 

handler.  

Parameter - [Add] 

button  

Add a parameter.  

Messages - 

 

Order number of the messages. 

Messages - Description  

 

External name of the message. This name is displayed on the 

[Flow]  tab of the form models in the ôDescriptionõ column. 
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Messages - Code 

 

Internal name of the message, as programmed in the Java code.  

Messages - Message 

 

Message text (for example, an error message or the body of an 

e-mail). This name is displayed on the [Flow]  tab of the form 

models in the ôContentõ column. 

Messages - Decentral  

 

Whether this message is defined in the model (=  central) or on the 

page (= decentral).  

Messages - Delete 

 

Delete this message by checking the check box and saving the 

handler.  

Messages - [Add] button  Add a message. 

 

Dedicated parameter - 

Code 

Internal name of the parameter, as programmed in the Java code.  

Dedicated parameter - 

Parameter  

Contents for the parameter.  

For example, there is a dedicated ôupdate queryõ parameter in the 

DatabaseUpdateHandler that should be filled with the relevant 

UPDATE statement. 

Dedicated parameter - 

Delete 

Delete this dedicated parameter by checking the check box and 

saving the handler.  

Restricted to category  

 

Select the form model categories (defined on the [Categories]  

tab), for which this handler should be listed on the [Flow]  tab. If 

no category is selected, this handler will be displaye d for all form 

models. 

Used in form  

 

List of form models where this handler is used.  
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2.4.2  Form validato r  

For rules of the ôForm validatorõ type, validators are defined that can later be used in the flow of 

form models.  

 

Select menu Maintain > Forms > Option s > [Rules]  tab > Select type = ôFormulier 

validatieõ. 

 

Example: 
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The fields on this screen have the following meanings:  

Field  Description  

Basic - Name 

 

Name of the form validator as it should be listed in 

GX WebManager. 

Basic - Description  

 

Form validator description. This is displayed on the form modelõs 

flow if this rule is selected.  

Parameters can be used here to insert fields and, for example, to 

pass on the sequence of the fields to the user (through the 

description of  the parameter).  

Basic - Available  

 

Whether this form validator may be used in the form models.  

Basic - Label 

 

Rule type (ôHandlerõ, ôForm validatorõ, ôRouterõ, or ôValidatorõ). 

Basic ð Java handler class 

 

Java class called by this form validator.  

Basic ð Additional 

identifier  

Internal name of the rule. Fill this field if something should be 

done in the code.  

Basic - Precondition  

 

Condition that has to be met before the form validator is started.  

Javascript template  

 

Client -side check before SUBMIT. Usually, a form is checked on the 

server.  

Basic - Resource 

 

This field will be removed.  

Basic ð Connection name 

 

Select the name of the relevant resource, as defined on the 

[Resources]  tab. This connection name is used by handlers that 

execute a query and  can only be selected if the handler needs a 

connection name.  

In this location, warnings and error messages that pertain to the parameters, dedicated 

parameters, and messages, appear in red.  

Parameter - 

 

The parameterõs sequence when the parameterõs values are 

entered on the form model.  

Parameter - Description  

 

Text that appears as the label of the parameter when the value is 

entered, if @parametercode@ is used in the form validator.  

Parameter ð Code 

 

Name of the parameter, as programmed in the Java cod e. This 

code cannot be modified.  

Parameter - Type 

 

Parameter type:  

¶ Text (plain text can be entered)  

¶ Form part (a selection from form parts can be made)  

¶ Form part value (a selection from form part values can be 

made) 

¶ Number (a number can be entered)  

¶ Page (a page selection can be made) 

¶ Form step (a selection from form steps can be made)  

¶ Entered value (a selection from values can be made)  
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Parameter - Multiple  

 

Whether multiple values can be entered for this parameter.  

Parameter - Decentral  

 

Whether this par ameter is defined in the form model (=  central) or 

in the content element on the page (=  decentral).  

Parameter - Delete 

 

Delete this parameter by checking the check box and saving the 

form validator.  

Parameter - [Add] 

button  

Add a parameter.  

Messages - 

 

Order number of the messages. 

Messages - Description  

 

External name of the message. This name is displayed on the 

[Flow]  tab of the form models in the ôDescriptionõ column. 

Messages - Code 

 

Internal name of the message, as programmed in the Java code.  

Messages - Message 

 

Message Text (for example, an error message or the body of an 

e-mail). This name is displayed on the [Flow] tab of the form 

models in the ôContentõ column. 

Messages - Decentral  

 

Whether this message is defined in the model (=  central) or on the 

page (= decentral).  

Messages - Delete 

 

Delete this message by checking the check box and saving the form 

validator.  

Messages - [Add] button  

 

Add a message. 

Dedicated parameter - 

Code 

Internal name of the parameter, as programmed in the Java co de. 

Dedicated parameter - 

Parameter  

Contents for the parameter.  

Dedicated parameter - 

Delete 

Delete this dedicated parameter by checking the check box and 

saving the form validator.  

Restricted to category  

 

Select the form model categories (defined on th e [Categories]  

tab), for which this form validator should be listed on the [Flow]  

tab. If no category is selected, this form validator will be displayed 

for all form models.  

Used in form  

 

List of form models where this form validator is used.  

 



CONNECTIVITY MANAGEMENT 

Advanced Forms   

 

 
   E  info@gx.nl      WWW.GX.NL     24/ 83  

 

2.4.3  Router  

For rules of the ôRouterõ type, (conditional) jumps to other pages or steps are defined that can 

later be used in the flow of form models.  

 

Select menu Maintain > Forms > Options > [Rules]  tab > Select type = ôRouteringõ. 

 

Example: 
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The fields on this screen have the following meanings:  

Field  Description  

Basic - Name 

 

Name of the router as it should be listed in GX  WebManager. 

Basic - Description  

 

Router description. This is displayed on the form modelõs flow if 

this rule is se lected.  

Parameters can be used here to insert fields and, for example, to 

pass on the sequence of the fields to the user (through the 

description of the parameter).  

Basic - Available  

 

Whether this router may be used in the form models.  

Basic - Label 

 

Rule type (ôHandlerõ, ôForm validatorõ, ôRouterõ, or ôValidatorõ). 

Basic ð Java handler class 

 

Java class called by this router.  

Basic ð Additional 

identifier  

Internal name of the rule. Fill this field if something should be 

done in the code.  

Basic - Precondition  

 

Condition that has to be met before the router is started.  

Basic - Resource 

 

This field will be removed.  

Basic ð Connection name 

 

Select the name of the relevant resource, as defined on the 

[Resources]  tab. This connection name is used by handle rs That 

execute a query and can only be selected if the handler needs a 

connection name.  

In this location, warnings and error messages that pertain to the parameters, dedicated 

parameters, and messages, appear in red.  

Parameter - 

 

The parameterõs sequence when the parameterõs values are 

entered on the form model.  

Parameter - Description  

 

Text that appears as the label of the parameter when the value is 

entered, if @parametercode@ is used in the router description.  

Parameter ð Code 

 

Name of the parameter , as programmed in the Java code. This 

code cannot be modified.  

Parameter - Type 

 

Parameter type:  

¶ Text (plain text can be entered)  

¶ Form part (a selection from form parts can be made)  

¶ Form part value (a selection from form part values can be 

made) 

¶ Number (a number can be entered)  

¶ Page (a page selection can be made) 

¶ Form step (a selection from steps can be made)  

¶ Entered value (a selection from values can be made)  

Parameter - Multiple  

 

Whether multiple values can be entered for this parameter.  
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Parameter - Decentral  

 

Whether this parameter is defined in the form model (=  central) or 

in the content element on the page (=  decentral).  

Parameter - Delete 

 

Delete this parameter by checking the check box and saving the 

router.  

Parameter - [Add] 

button  

Add a parameter.  

Messages - 

 

Order number of the messages. 

Messages - Description  

 

External name of the message. This name is displayed on the 

[Flow]  tab of the form models in the ôDescriptionõ column. 

Messages - Code 

 

Internal name of the message, as programmed i n the Java code.  

Messages - Message 

 

Message text (for example, an er ror message or the body of an 

e-mail). This name is displayed on the [Flow] tab of the form 

models in the ôContentõ column. 

Messages - Decentral  

 

Whether this message is defined in the model (= central) or on the 

page (= decentral).  

Messages - Delete 

 

Delete this message by checking the check box and saving the 

router.  

Messages - [Add] button  

 

Add a message. 

Dedicated parameter - 

Code 

Internal name of the parameter, as programmed in t he Java code. 

Dedicated parameter - 

Parameter  

Contents for the parameter.  

Dedicated parameter - 

Delete 

Delete this dedicated parameter by checking the check box and 

saving the router.  

Restricted to category  

 

Select the form model categories (defined on the [Categories] 

tab), for which this router should be listed on the [Flow]  tab. If 

no category is selected, this router will be displayed for all form 

models. 

Used in form  

 

List of forms where this router is used.  
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2.4.4  Validator  

For rules of the ôValidatorõ type, validity checks are defined that can be used later for the 

different form parts in the steps of form models.  

 

Select menu Maintain > Forms > Options > [Rules]  tab > Select type = ôValidatieõ. 

 

Example:  
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The fields  on this screen have the following meanings:  

Field  Description  

Basic - Name 

 

Name of the validator as it should be listed in GX  WebManager. 

Basic - Description  

 

Validator description. This is displayed on the form modelõs flow if 

this rule is selected.  

Parameters can be used here to insert fields and, for example, to 

pass on the sequence of the fields to the user (through the 

description of the parameter).  

Basic - Available  

 

Whether this validator may be used in the form models.  

Basic - Label 

 

Rule type (ôHandlerõ, ôForm validatorõ, ôRouterõ, or ôValidatorõ). 

Basic ð 

Regular expression 

Format the input has to meet.  

Example: 

For the Netherlands, a ZIP code has to meet the regular expression  

\ s* \ d{4} \ s*[a - zA- Z]{2} \ s*  

(This means: spaces, 4 numbers, spaces, 2 letters, spaces)  

See http://www.regular -expressions.info/reference.html  for an 

overview of the regular expressionsõ syntax. 

Basic ð Java handler class 

 

Java class called by this valid ator.  

Basic ð Additional 

identifier  

Internal name of the rule. Fill this field if something should be 

done in the code.  

Basic ð Additional field  This text is shown on the page next to the label of the fields where 

this validator has been assigned to.  

Basic ð Only for  

 

This validator can only be used for these form part types. If no 

types are selected, this validator will be displayed for all form 

parts.  

Possible selections: 

¶ Uploading file  

¶ List 

¶ Exception 

¶ Subform 

¶ Text input field  

Basic - Resource 

 

This field will be removed.  

Basic ð Connection name 

 

Select the name of the relevant resource, as defined on the 

[Resources]  tab. This connection name is used by handlers that 

execute a query and can only be selected if the handler needs a 

connection name.  

In t his location, warnings and error messages that pertain to the parameters, dedicated 

parameters, and messages, appear in red.  

http://www.regular-expressions.info/reference.html
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Parameter - 

 

The parameterõs sequence when the parameterõs values are 

entered on the form model.  

Parameter - Description  

 

Text th at appears as the label of the parameter when the value is 

entered, if @parametercode@ is used in the validator description.  

Parameter ð Code 

 

Name of the parameter, as programmed in the Java code. This 

code cannot be modified.  

Parameter - Type 

 

Parameter type:  

¶ Text (plain text can be entered)  

¶ Form part (a selection from form parts can be made)  

¶ Form part value (a selection from form part values can be 

made) 

¶ Number (a number can be entered)  

¶ Page (a page selection can be made) 

¶ Form step (a selection from st eps can be made) 

¶ Entered value (a selection from values can be made)  

Parameter - Multiple  

 

Whether multiple values can be entered for this parameter.  

Parameter - Decentral  

 

Whether this parameter is defined in the form model (=  central) or 

in the content  element on the page (=  decentral).  

Parameter - Delete 

 

Delete this parameter by checking the check box and saving the 

validator.  

Parameter - [Add] 

button  

Add a parameter.  

Messages - 

 

Order number of the messages. 

Messages - Description  

 

External name of the message. This name is displayed on the 

[Flow]  tab of the form models in the ôDescriptionõ column. 

Messages - Code 

 

Internal name of the message, as programmed in the Java code.  

Messages - Message 

 

Message Text (for example, an error message or the body of an 

e-mail). This name is displayed on the [Flow]  tab of the form 

models in the ôContentõ column. 

Messages - Decentral  

 

Whether this message is defined in the model (=  central) or on the 

page (= decentral).  

Messages - Delete 

 

Delete this message by checking the check box and saving the 

validator.  

Messages - [Add] button  

 

Add a message. 

Dedicated parameter - 

Code 

Internal name of the parameter, as programmed in the Java code.  

Dedicated parameter - 

Parameter  

Contents for the parameter.  

Dedicated parameter - 

Delete 

Delete this dedicated parameter by checking the check box and 

saving the validator.  
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Restricted to category  

 

Select the form model categories (defined on the [Categories]  

tab), for which this validator should be listed on the [Flow]  tab. 

If no category is selected, this validator will be displayed for all 

form models.  

Used in form  

 

List of forms where this validator is used.  

 

2.4.5  Creating and deleting rules  

In GX WebManager, many rules are predefined. If a new rule should be created, this can be done 

in two ways:  

¶ Creating a complete new rule, by selecting ôNew ruleõ from the pull-down menu (see A in 

the image below ) and setting it up.  

¶ Using an existing rule, by copying this rule with the [Copy] button ( see B) and 

adjusting it.  

 

It is also possible to delete unnecessary rules. This however, only works if that rule is not used in 

any form model. If that is the case, [Delete]  will be grayed out ( see C).  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 












































































































