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DISCUSSION & GUESTBOOK Interaction Management

SUMMARY

A discussion (also known as a forum) allows visitors to respond to statements and questions
from other visitors. It is also possible to start a new (sub)discussion yourself. Discussions can
be followed on the website and reactions can be added. The editor has the option of
moderating discussion reactions either before or after they are posted.

This functionality can also be set up as a guestbook which allows individual comments to be
posted instead of interactive discussions.
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1 CREATING A DISCUSSION

Using the Discussion content element, two types of discussions can be maintained: Forum and
Guestbook. The difference between the two is that in a forum you can comment on other visitors’
comments and in a guestbook you cannot. Besides creating specific formats for discussions and
creating discussions based upon these formats, it is also possible to moderate discussions.

To place a discussion element on a page, a discussion model and a discussion name have to be
created first.

1.1 Discussion name

To create a new discussion, navigate to Maintain > Discussions > and click the

[Discussions] tab:

Y  Select ‘New discussion’.

3 MyWeb - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate

Select b Select = Select discussion %
Select discussion

|
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Give the discussion a name.

<

Select ‘No’ next to ‘Closed’ because the discussion has not yet started.

=<

2 MyWeb - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate
Select b Select |New discussion v|
Basic settings Discussion name: |Sp0rts |

Closed: Ovyes @ Mo
Moderation

User groups:

Maone

add:

= Select v

W

Y If desired, limit the moderation of the discussion to specific user groups. These user
groups can be defined in the Configure > Authorization menu. If no user group is
selected, any user authorized to do so (on the [Moderate] tab) is allowed to moderate
this discussion.
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1.2 Discussion model

A discussion model defines the general setup of a discussion. The general setup controls the
number of messages that are shown, whether a discussion can be moderated, and who can
participate in a discussion. To create a new discussion model, select the [Discussion models]
tab from the Maintain > Discussions.

Y Select ‘New discussion model’.

2 MyWeb - Discussions - Microsoft Internet Explorer = || g
s
Maintain - Discussions —
Discussion models Discussions Moderate
Choose P Choose | = Choose discussion model
discussion = izhoose discussion model
rmodel i i

Y  Give the model a name (see A in the image below ).

2 MyWeb - Discussions - Microsoft Internet Explorer,

Maintain - Discussions —

Discussion models Discussions Moderate
Choose P Choose | yew discussion maodel v|
discussion
rnodel
Model Model name: o Sports |
Maderation: Post-moderated |+
Presentation: W Farum v

Maximum thread depth:

Mumber of threads to show at start:

Is published: Oives (Mo

Everyone rmay post: OYes @ND
Wha may post?: [

v

Close

Y Determine whether the moderating should be performed before or after postings.
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Y Select the desired appearance next to ‘Presentation’. By default, there is a choice
between a forum and a guestbook.

Y Determine the ‘Maximum thread depth’ (the total number of responses to be displayed).
If this field is left blank, there is no limit.

Y Determine the number of topics to be shown on the page next to ‘Number of threads to
show at start’. If the number of topics is higher than this value, numbered links to
subsequent pages containing the remaining topics appears on the website. The default
value is 2.

Y  When the model is ready for use, select ‘Yes’ next to ‘Is published’

Y Determine who is allowed to participate in the discussion. If ‘No’ is checked next to
‘Everyone may post’, an additional field appears where specific web user groups can be
assigned. These groups can be defined on the [Web groups] tab from the Configure
> Web users menu. A visitor from another web user group may read the discussion but
is not allowed to participate.

[ | | | |
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2 PLACING A DISCUSSION ON A PAGE

To place the discussion element on a page, follow these steps:

Y Add the discussion content element to a page: Insert > User interaction >

Discussion.

Y  Select the name of the discussion model and discussion from the respective lists.

&% Discussion e BHE A
Discussion model: | Sparts model v|
Discussion name: | Sparts v|

The discussion is now open but empty on the website because there have not yet been any posts:

OPEN FOR BUSINESS

MyWeb > Content » Discussion

poll Discussion
» Discussion Title Author Date Posts

New topic
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When the visitor clicks [New topic] to the right of a new discussion, a new thread is started. A
new message form displays in which the visitor can create their new message. This will be a new
topic within the scope of the current discussion:

OPEN FOR BUSINESS

MyWeb Content Discussion

Pall Discussion

» Discussion

New message

Title

|Spons injuries |
Author

John Doe

Message

I've been a foothall A
coach for the past 15
years and in that time 3
I've noticed a dramatic
increase in the number v

L Send-message ]

When the visitor clicks [Send message], the message is added to the discussion, however, since
this is a pre-moderated discussion, the message will not appear for others to see until the
moderator has approved the message. If this had been a ‘Post-moderated’ discussion, the message
would have been shown immediately. Moderators have the option of adjusting post-moderated
messages at a later time or deleting them altogether.
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3 MODERATING DISCUSSIONS

To moderate discussions, select the [Moderate] tab from the Maintain > Discussions
menu. From here you can adjust, close or delete threads and messages in order to keep
discussions up-to-date and manageable.

Discussion messages are either pre- or post-moderated. The advantage of pre-moderated
discussions is that you can control the text that is published and weed out postings containing
inappropriate language/content. Pre-moderated messages are only published after the moderator
has approved them. The disadvantage of pre-moderated messages is that there can be delays
between when a message is posted and when it appears on the website and this can tend to make
discussions less spontaneous. Post-moderated messages are typically more appropriate for
discussions that allow only registered users to participate.

3.1 Moderating a thread

Moderate a thread as follows:

1. The [Moderate] tab from Maintain > Discussions shows all the active discussions.
For example:

2 MyWeb - Discussions - Microsoft Internet Explorer,

Maintain - Discussions

Discussion models Discussions Moderate

Discussions ou can rioderate the follawing discussions:
State = Choose v

v

Apply | Close

| | |
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2. Select the discussion you want to moderate from the list (in this example we select the

‘Sports’ discussion):

| MyWeh - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate
Discussions You can moderate the following discussions:
State | = Choose b
Sports
IMusg
Traw
Hobbies

W

After you select the discussion, an overview of the discussion and message threads

appears:

23 MyWeb - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate

Discussion Discussion name Sports
Thread Sports injuries

Messages Message
This thread contain no messages,

Back Back to thread overview

Close Delete

s

3. Click the link for the discussion in the Discussion overview.
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A dialog box containing the message that need to be moderated appears:

2l MyWeb, - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate

Discussion Discussion name Sports

Edit message State Mew and non-public v
Title Sports injuries
MESSALE 1'ye heen s football coach for the past 15 years and in that time ['ve noticed a dramatic increase in the
number of injuries my players have sustained.
Back Back to messages overview

In the case of this message (‘Sports injuries’), its initial state is ‘New and non-public).
You have the option at this point of selecting ‘Public’ or ‘Rejected’ as a new state for
this message.

4. Select ‘Public’ to approve this message and to allow it to be seen by all website visitors
or ‘Rejected’ to disallow it. In this example we select ‘Public’.

Edit message State Mew and non-public

Title Mew and non-public

Message ([ o1 red h for the past 15 years and in that time I've noticed a dramatic increase in the

nurmber of injuries my players have sustained,

| | |
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5.

Click ‘Back to discussions overview’. Now when you select the discussion from the list, in
this case ‘Sports’, the approved message now appears in the ‘Threads’ list:

3l MyWeb - Discussions - Microsoft Internet Explorer,

Maintain - Discussions

Discussion models Discussions Moderate
Discussion Discussion name Sports
Threads Thread Close Delete

Sports injuries

Back Back to discussions overview

Close

The thread is now visible on the website:

OPEN FOR BUSINESS

Myweb Content Discussion

Poll

Blscussion Title Author Date Posts
Sports injuries John Doe  21-01-2008 16:14 0

New topic

On the [Moderate] tab in the Edit environment, you can select ‘Close’ or ‘Delete’ to
close or delete the thread. A closed thread remains visible on the website, but
comments can no longer be posted. Deleting a thread erases the entire thread from GX
WebManager permanently, including all responses.
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3.2 Moderating a message

Moderate a message as follows:

1. The [Moderate] tab from Maintain > Discussions shows all the discussions:

2 MyWeb - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate
Discussions You can moderate the following discussions:
Sports
Music
Travel
Hobhies

Close

2. Select the discussion from the discussion list (in this example, ‘Sports’):

2 MyWeb - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate

Discussian Discussion name Sports

Threads Thread Close Delete

o 0O

Sports injuries

Back Back to discussions averview

| |
<GX> CREATIVE ONLINE DEVELOPMENT B.V. e-mail info@gx.nl http://www.gx.nl/ 15/18




DISCUSSION & GUESTBOOK Interaction Management

3. Select the relevant thread (in this example, ‘Sport injuries’ was chosen). In this example
several messages have been added that need to be moderated.

3 MyWeb - Discussions - Microsoft Internet Explorer

Maintain - Discussions
Discussion models Discussions Moderate
Discussion Discussion name Sports
Threads Thread Close Delete
Proper use of equiprnent
Sports injuries il il
Training i "]
wou're all stupid 1 O
Back Back to discussions overview

4. Click a message to view it and to change its state from ‘New and non-public’ to ‘Public’
or ‘Rejected’. In this example, “You’re all stupid” has all the hallmarks of a message
that is most likely inappropriate and needs to be rejected.

5. Click a message to view it. An overview of the message will appear that lists the
reactions that have been sent:

2 MyWeb - Discussions - Microsoft Internet Explorer,

Maintain - Discussions

Discussion models Discussions Moderate

Discussion Discussion name Sports
Thread You're all stupid

Messages Message Close Delete
This thread contain no messages.

Back Back to thread overview

Close
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Click the link for the message next to Thread to view the message:

EEX

Why don't you find something mare intersting to talk about

2 MyWeb - Discussions - Microsoft Internet Explorer
Maintain - Discussions
Discussion models Discussions Moderate
Discussion Discussion name Sports
Edit message State
Title You're all stupid
M&sS308 yhat & stupid and boring discussion this is.
like nude beaches or Kurt Cobain?
Back Back to messages overview

Since this message is not suitable for the forum, it is rejected. This message is now no

longer visible in the thread. However, it still exists in GX WebManager and its state could
be changed to ‘Public’ in the future.
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3.3 Presenting a discussion model

The [Presentation] tab in the Format > Presentation menu allows you to select a forum
or a guestbook for a discussion model. This allows you to control the look and feel of the
discussion.

Y Navigate to the Format > Presentation and click the [Presentations] tab:

- Microsoft Internet Explorer

Format - Presentation

Presentations Presentation folders Page parts
Select 4 Scope Presentation
ForumSettings ~ | WM Forum v

Meta information name WM Forum
MHame WM Forum
Ranking

Default presentation is ®ves ONo
selectable
Meta information folder C:\GH\WebManager®twebmanageriywebappsibackendyWER-
INFyprojectsnl.gx. product.wmpeornmunityeditionstyledfarurmifarum Contraller xml

Location SWEB-INF/project/nl.ax product.wmpcommunityeditionstyleforumforumContraller jspf
Scope ForumSettings
Prewiew image

Froperties Name Description Datatype Default
even_color Achtergrondkleur even Color E3iiniid
odd_colar Achtergrondkleur oneven Caolor #eTebef
header_color Achtergrondkleur header Caolor #hac?cf
normal Mormalclass Font normal
header Headerclass Fant header
niormal Mormnalclass Font normal
header Headerclass Faont header
norrnal Mormalelass Fant norrnal
header Headerclass Font header

Select wariant = Select ¥ [ New presentation wariant ]

Apply | Close

You can define new presentation variants by clicking [New presentation variant].

The properties determine the appearance of (in this case) the guestbook. The [Send] button, for
example, is shown and in the discussion overview, odd rows (#e7ebef =|:| ) differ in color from
even rows (#ffffff = |:|). Further explanation about presentations and presentation variants is
beyond the scope of this document.
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