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SUMMARY

With this functionality the user can publish pages and let these be shown in different places
in overviews that are being put together by the editors (page collections). This way, for
instance, dynamic archives can be set up. So, with the help of this module, overviews of
pages can be generated. There are three filters are available: an age filter, a label filter, and
a date filter.

PREREQUISITES

Content Management
e Basic Content Management

RELATED TOPICS

Content Management
e Advanced Content Management

Connectivity Management
e Media Repository

VERSION CONTROL

Version ‘ Date ‘ Description

1.0 March 7, 2006 Initial version

1.1 March 24, 2006 Corrections implemented

1.2 July 17, 2006 Updated to GX WebManager 8.3
2.0 July 6, 2007 Updated to GX Webmanager 9.1.0
2.01 February 26, 2008 | Added document ID on title page
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1 DESCRIPTION OF A PAGE

Every page can have a description. A summary can be put here.

The description is not shown on the page itself but is used to direct to a page, for example within
the Page collection content element. The description is also used when internal or external
search engines are searching for the page. Without a description, the first part of the page text
would be shown, which may not always be representative.

To add a description to a page, proceed as follows:

= Select the Insert > Introduction menu. A blank description element appears on
the page.

= Enter a introduction and save changes:

D MyWeb Version: 1 of 1 | walidity: 5/7f2007- State: Current version - Gepubliceerd | - |

Mavigation title: IPaga collection State: | Gepubliceerd vl ‘ More options » |

Introduction

Show the 5 most recent pages

Page collection

LI:I-] Page collection: New pages

Presentation: ‘ WM Page collection element

Title: |Naw pages
Selection criteria

Only show pages underneath: Horme

Adjust

& Only show newest pages
() Display newest pages from I:l

Wl

Filter({s)

| = Select hd |

Links

Subsequent pages

Do not show in navigation

The introduction can now be used by the page collection element, for example.
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2 PAGE LABELS

To search for specific page types, one or several page labels can be assigned to each page. This
way, only those pages with a specific label can be shown for a page collection element.

To add page labels to a page, proceed as follows:
= Select the File > Properties > Labels (Page) menu. A window appears that

allows creating the labels. On the [Assign] tab, page labels can be assigned to the
current page:

2} MyWeb - Labels : Modify content settings of "Page collection” - Microsoft Intern... g@

File - Labels (page)...
Assign Maintain

Available labels: Selected labels:

| Apply ‘ ‘ Close

Since there are no labels yet, there is nothing to select.

[ | | |
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On the [Maintain] tab, the page labels can be created; this tab also shows which
labels are assigned to which pages:

2} MyWeb - Labels : Modify content settings of "Page collection” - Microsoft Intern... |

File - Labels (page)...

Assign Maintain

— MEW LABEL

[Create ]

— MAMAGE EXISTING LABELS ———————— — SELECTED LABEL I5 USED ON

‘ Apply ‘ | Close

= Enter page labels on the [Maintain] tab and click [Apply]:

3 MyWeb - Labels : Modify content settings of *Page collection” - Microsoft Intern... EE|

File - Labels {page]...

Assign Maintain

— MEW LABEL

[create ]

— MANAGE EXISTING LABELS ——— — SELECTED LABEL IS USED ON

Basic Content Managernent {0}
Extended Content Management (0)
Mews (Archives & Qverviews) (0}

| Apply | | Close
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= Onthe [Assign] tab, assign one or several page labels to the current page by selecting
the relevant label and clicking [Add label]. To remove a page label from the list of
selected labels, select the relevant page label and click [Remove]:

<3 MyWebh - Labels : Modify content settings of "Page collection” - Microsoft Intern...

File - Labels (page)...
Assign Maintain

Awailable labels: Selected labels:

Basic Content Managerent
Extended Content Management

| < Remowe |

‘ Apply ‘ | Close

= Click [Apply] and [Close].

On the page, when clicking the [More options] button to view the page information, it is also
possible to view (and adjust) which page labels are assigned to this page:

D MyWeb Version: 1 of 1 | Walidity: 22f6/2007- State; Current version - Gepubliceerd | =

Mavigation title: |F‘age collection | State:| Gepubliceard w | | « Less options |

Publication date: 22/6/2007 |[11:37 |[G  Expirationdate:] | |[EH
Include in search engine Comment:| |

Page nr: 65276 Created: 22/6/2007 11:37:03 by Administrator
Last modified: 29/6/2007 11:29:28 by Caroline Hovers

Page version nri 67853

Labels: News {Archives & Overviews)
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3 SETTING UP AND PLACING A PAGE COLLECTION

An overview of pages can be generated using the Page collection content element. This places the
most recent pages of the website automatically in an overview on the page, provided they meet
certain conditions. Labels assigned to pages can be used as filters within the page collection.

3.1 Simple selection criteria

Objects from the Media Repository are shown in the Media overview and Media list content
elements. Pages from the site structure are shown in the Page collection content element.

Initially, the page collection element looks like this:
D page collection -

Presentation: | WM Page collection elerment v

Title: |

Selection criteria

Only show pages underneath: Horme
Adjust
) Only show newest 10 pages
() Display newest pages from
to
Filter({s)
= Select v

= Enter a ‘Title’ for the page collection. The title appears at the front above the pages
overview.

= Select the desired appearance from the ‘Presentation’ pull-down menu:

o ‘WM Page collection element’ shows the page title, the publication date and,
possibly, a description of all pages found.

o ‘WM Page collection element Atom 1.0 feed’ is one of the RSS standard
elements and is meant to allow this page to be offered as RSS feed.

o ‘WM Page collection element full content’ shows the entire contents of all
pages found.

o ‘WM Page collection element RSS 2.0 feed’ is one of the RSS standard elements
and is meant to allow this page to be offered as RSS feed.

= At ‘Only show pages underneath’, indicate the page tree start location for the list
compilation. By default, GX WebManager uses the root page. This is the ‘Home’ page in
the case of the course environment. This page is not included in the list of displayed
pages.

[ | | |
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= At ‘Only show newest X pages’, indicate how many page links should be shown (default is

10) or at ‘Display newest pages from X to Y’, indicate which group of page links should

be displayed. (Enter the ‘from page’ and the ‘to page’ number. For example, enter ‘2’

and ‘5’ to exclude the most recent pages, but to include the next four pages.)

The following settings are now configured:
519 Page collection

Presentation: | WM Page collection elerment

Title: |New pages
Selection criteria

Only show pages underneath:

(3 Only show newest
() Display newest pages

Filter{s)

> Select

v
Horme
Adjust
5 pages
fram
ta
v
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3.2 Filters as selection criteria

= At ‘Select filter(s)’, it is possible to assign extra filters in order to show only pages that
meet those requirements:

o For an age filter, indicate the maximum or minimum age (in days) of a page, in
order to be shown. The choices are: ‘all pages of maximum X days old’ and ‘all,
except pages of maximum X days old’:

[_[D Page collection: Pages of max 100 days old -

Presentation: | WM Page collection elernent v

Title: |Pages of max 100 days old
Selection criteria

Only show pages underneath: Horne
Adjust

(= only show newest 5 pages

() Display newest pages from

Filter(s)

> Select v

Age filter: Show [ delete filter

all pages w

of maxirmumm | 100 days old
o With the date filter, filter on the publication date of pages. There are four
possibilities:

= Show only those pages that have a publication date on or before a
certain date:

[_E,D Page collection: New pages till May 7, 2007 -

Presentation: | WM Page collection element w

Title: |New pages till May 7, 2007

Selection criteria

Only show pages underneath: Horme
Adjust
(& ©Only show newest 5 pages
() Display newest pages from
to
Filter{s)
= Select v
Diate filter: Show [ delete filter
all pages w
frorm Hel

and end date 7/5/2007 B

[ | | |
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= Show only those pages that have a publication date from a certain

date:
[_E,D Page collection: New pages after February 20, 2007 ® HEEd
Presentation: | WM Page collection element w
Title: |New pages after February 20, 2007
Selection criteria
Only show pages underneath: Horme
Adjust
(& ©Only show newest 5 pages
() Display newest pages from
to
Filter{s)
= Select v
Diate filter: Show [ delete filter
all pages w
from 20/2/2007 A

and end date @

=  Show only those pages that have a publication date between or on two

dates:
[_E,D Page collection: New pages between February 20 and May 7, 2007 ® HEE
Fresentation: | WM Page collection element L
Title: |New pages between February 20 and May 7,
Selection criteria
Only show pages underneath: Horme
Adjust
& Only show newest 5 pages
() Display newest pages from
to
Filter{s}
= Select w
Diate filter: Show [ delete filter
all pages L
from 20/2/2007 A

and end date 7/5/2007 B
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= Show all pages, except those that have a publication date between or

on two dates:
[_E,D Page collection: New pages before February 20 and after May 7, 2007 - =1 x|

Presentation: | WM Page collection element v

Title: |New pages before February 20 and after Ma»

Selection criteria

Only show pages underneath: Horme
Adjust
& only show newest 5 pages
() Display newest pages from
to
Filter(s)
= Select v
Diate filter: Shaw [ delete filter
all, except pages v
from 20/2/2007 A

and end date 7/5/2007 B

o A label filter allows indicating which label a page should have in order to be
shown in the overview of the page collection. Page labels can be created and
assigned in the File > Properties > Labels (Page) menu:

Li__.n Page collection: Pages for the module 'Basic Content Management' -

Presentation: | WM Page collection element -

Title: |Pages for the module 'Basic Content Manage

Selection criteria

Only show pages underneath: Horme
Adjust
(& Only show newest 5 pages
() Display newest pages from
to
Filter(s)
= Select w
Label filter: Only show pages with these labels [ delete filter
= Select label w

= Select label

[Basic Content Management
Extended Content Management
Mews (Archives & Overviews)

Note: If several filters are selected, only those pages are shown that meet the
requirements of all filters.

| |
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3.3 End result

Once set up, no maintenance is required for the Page collection content element. New pages
appear automatically in the overview.

The result might look like this:

OPEN FOR BUSINESS

Content without Content Website External databases Forms Personalization
configuration configuration maintenance

Home » Content with configuration » Qwerview » Page collection <Mederlands >

Banners Page collection

MS Office imports

PDF Generator
Pages of max 100 days old
Check spelling

Language switch Siternap
(28-06-2007)

Media R it " . o .
sdia Fepository Here you can find an overview of all pages within this website, To go to a page, just click on the

ObjectManager page name,
» Ouerview WMOTSTWTG
(22-06-2007)
Fag Introduction
Calendar overview (22-08-2007)
Shows the 5 most recent pages ”
Falder

Redirect page
» Page collection (22-06-2007)
Table

Froducts (22-06-2007)

Query Text
(22-06-2007)
Meetings & Papers Separator
(22-06-2007)
Whosis-he with planes
(2z2-06-2007)
User interaction Paragraph
(22-06-2007)
Connectars with HTML

Page sections (22-08-2007)

Page templates

A couple of pages show some text (see A in the image above) and other pages do not. This is the
description that has or has not been added to a page. Page descriptions can be entered using the
Insert > Introduction menu.
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