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SUMMARY

PAGE TEMPLATES Content Management

In GX WebManager, so-called page templates can be used. A page template is a pre-defined
page format and setup. The authorization can be set in such a way that specific editors can
only use certain page templates. ‘Press Release’ and ‘Job Opening’ are typical page

templates.
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1 INTRODUCTION

A page template is a pre-formatted page for use in the site structure. The website administrator
defines - among other things - which content elements and page sections will appear on the page,
and in what order, who is allowed to use the page template, and who is allowed to make
modifications. Also, pages based on an old version of a page template, can be automatically
updated to a new version of that page template.

A page template can be used in situations where there is a need for consistent format and
structure of the pages. This is, for example, the case when creating job openings or press
releases for a website. When creating new pages, editors can, besides the regular options like
‘New page, ‘Copy page’ and ‘New version’, make a selection from pre-defined page templates:

Fl=8 Edit Ingert Maintain Format Configure Help

=0y 3 Page
Search page...

Preview page...

Versi
= save Alt+S sreion
Save copy
Import...
P El article
Export...
P Multimedia
Product page

Save in Media Repository Sl e O pETE

Regelgeving page
Celete Vergader agenda/verslag page

Persoon page
Froperties 3 pag

My WebManager... PersonDetailview page

PersonDetailviewComplex page

[ R

In this document the creation of a page template for a vacancy will serve as an example. This
page model consists of a piece of non-editable standard text, an image, and a piece of editable
text. Besides that, a select group of editors can be authorized to use this page template.

[ | | |
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2 SETTING UP A NEW PAGE TEMPLATE

Setting up a page template is done in three steps:

1. Creating a new page template, determining who is allowed to use it, and defining the
initial content elements it contains.

2. Defining settings that are related to personalization, page sections, meta keywords, and
design.

3.

Publishing the page template, so that it can be used.

2.1 Creating a new page template

Note: To be able to create a page template, the option ‘Page template’ should be ticked on the

‘Functionalities’ tab in the Config ur e > Web Initiative configurati on menu.

Website managers can create a new page template, through the [Page templates] tab:

= Select the [ Page templates ] tab and choose File > New > Page template

File Edit Insert Maintzin Format Configure Help

Iy WiehhManager Log out (Administratar
English ¥ $= IS S i

L@ Fages

B Fage sections [Z My pagemodel

Marme: My pagermodel
Media Repositary My pac

[ Iz published
L@ Pags templates I~ available in Media Repository
I™ additional elements allowed

Name

B wy pagemodsl

Roles for this template
Add arole: ‘ = Select role

More settings

Preview

Enter a ‘Name’ for the new page template. This name appears in the File > New

menu
when the page template is published.

Determine at ‘Available in Media Repository’ if the template can only be used for pages,
or if it can also be used for media articles.
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= Determine at ‘Additional elements allowed’ if the user of the template (most of the time
an editor) is allowed to add extra content elements on the page.

= Determine at ‘Add a role’ who is allowed to use to this template. If no role is selected no
one is allowed to use this template

= Add as many content elements to this page template as desired. For example:
o A piece of non-editable standard text.
0 Animage.

0 A piece of editable text where the vacancy can be entered.

= Determine at ‘Editable’ in the content element if the user of the template is allowed to
change the element (see the image below):

@ Yacancy page =

Mame: [vacancy page

[ Is published

[ Available in Media Repository
[ additional elements allowed
Roles for this template

Editors [~ Delete

Add arole: | = Select role v

More settings

Paragraph: GX Offers A= -

[ Editable

Title: |5x Offrs

Link code: | Mare hd

Waorking for G¥ means involvement with cutting-edge technology. And of course, our own product,
G WiebManager, At G, we wark together clasely to deliver the top quality web salutions and
products that our custormers have come to expect frorm us,

Solutions that can only be conceived and realised by teams that are capable of contributing innovative
ideas, new perspectives and customer focus,

Image: <GX:> d=-x
I Editable
U Cemrinm ViSSR.
Note: If text is entered at the user of the template is not able to change it.
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2.2 Editing more settings for page templates

= Click the [More settings ]

= Go to the [Settings ] tab.

button on the page template.

= Define the parameters for this page template:

Maintain - Page templates

P Select a page template | Yacancy page v

FPages Settings

Read ¥ Select a personalization
arcess > Select v
¥ Access only for web users
Oes @No
Basic

» Othy
settings er

Use expiration date: O
LUsg HTTPS: "
Language: Dutch

¥ Models:
‘WWehlogging model: Geen waarde v
Block » Page sections
1 ¥ colliciteran
» Add new block

({jobapply-labely

Colofon
Gezondheidszorg
Info opvragen

Labels ¥ Add new label
Add label w

O pelete

Meta » overruling meta keywords for this page template

kewwords

Frarmework
Presentation: | > Sglact

Style: = Select

The fields on this screen have the following meaning:

Field ‘ Description
Read accessd Select a
personalization

template.

Select which users (web users with certain personalization
characteristics or all) may view pages based on this page

» overruling presentation settings for this page template

v

Apply | Close

Read accessd Accessonly

for web users this page template.

Select which users (web users only or all) may view pages based on

Basic settings 0 Use

expiration date expiration date.

Check here if pages based on this page template may have an

Basic settings 8Use HTTPS

Check here if pages based on this page template must be sent
using a secure connection.
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Field ‘ Description

Basic settings d Language Select the standard language of pages based on this page
template.

Basic settings 8 Weblogging Select which weblogging template should be used to save page

model view data for this page.

Block 8 Add new block Select the page sections for pages based on this page template.

Labels 8 Add new label Select the page labels to be initially assigned to pages based on

this page template.

Meta Keywords doverruling Enter different keywords here. If no metakeywords have been
metakeywords for this page entered in the page template, the standard keywords from the

template website will be inherited.

Framework & Presentation Select a different presentation. If no presentation has been
entered in the page template, the standard presentation will be
inherited.

Framework & Style Select a different style. If no style has been entered in the page

template, the standard style will be inherited.

I T T T ]
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2.3 Publishing a page template

= Close the [more settings] window. The page template will be visible (again).

= Tick the ‘Is published’ box:

D Yacancy page =

Mame: |Vacancy page

v .Is published
[ &vailable in Media Repository
[ additional elements allowed

Roles for this template

Editors [~ Delete

Add a role: | = Select rale A

More settings

= Save the page template. The following alert will appear: ‘Functionality has been
changed. Should GX WebManager restart?’.

= Click ‘OK’. After restarting, the page template is ready for usage.

[ | | |
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3 USING A PAGE TEMPLATE

After publishing and restarting GX WebManager, t
File > New

he page template ‘Vacancy page’ appears in the

menu. This is however only true for users in a group that is allowed to use this

template. For this example the page template ‘Vacancy page’ only appears for users in the role of

‘Editor’:

= Select the [Pages] tab and choose the
In this example it’s the ‘Vacancy’ page.

= Choose in the menu File

Z1E8 Edit Insert Maintain Format Configure Help

page where the new Vacancy page has to come.

> Ne w the Vacancy page:

My \WebManager Log out fadministrator)

MNew 3 Page
Freview page...
=l save Alt+S il
Save copy
Impart... H articis
Evport.. Multimedia
Move...
Product page
Save in Media Repository pEpRR R p—
Regelgeving page
Delete Wergader agenda/verslag page
Properties 3 P EEER
My Weblanager... PersDnDetaijView page‘

~
ity: 22/5/2007- | State: Current version - Gepublicesrd =
State: ‘Gepuhhceerd V| | « Less options

—
13 [EL Expiration date: B

engine Comment: ‘

Created: 22/6/2007 12:13:37 by Administrator
Last modified: 8/5/2008 09:47:52 by Administrator
itart
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When creating a new vacancy page, this page will look exactly the same as it was defined in the
page template:

Software architect

aragraph: GX Offers i

Title:

Link code:

Solutions that can only be conceived and realised by teams that are capable of contributing innovative
ideas, new perspectives and custormer focus,

Image: <GX> i

alternative text: | Position:

[~ Use as caption

Link code:

aragraph: Job title i =

Title: |1ob titls

Link code: |N0ne hd

|Jub Diescription

Note:
e The pre-defined content elements are paler in color.
e In this example only the second paragraph can be modified by the editor.

e In this example all options in the Insert menu are grayed out, because °‘Allow
Additional Elements’ was not checked.

= Name the page (in this example ‘Software architect’)

= Modify the editable elements as desired (in the example the job title and job
description: )

| | | |
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Paragraph: Software Architect i =

Title: |Suﬂware Architect

Link code: |None v

40 hours fweek
Lacation: Mijmegen

fou're an excellent technician and a creative, initiative and desicive architect with a big analytic
ability wham, by being a good listener and communicator is able to franslate the whishes and
demands of a client to a concept and developing this with team effort to a concrete technical
sloution,

= Change the state to ‘Published’. The page will look like this at the front:

Software architect
GX Offers

Wworking for G¥ rmeans invelvernent with cutting-edge technology, And of course, our own product, G¥ WebManager,
At GR, we work together clasely to deliver the top quality web solutions and products that our customers have corme
to expect from us,

Solutions that can only be conceived and realised by teams that are capable of contributing innovative ideas, new
perspactives and custorner focus,
Software architect

40 hoursfweeak

Location: Mijrnegen

vou're an excellent technician and a creative, initiative and decisive architect with a big analytic ability whorm, by
being 2 good listener and comrunicator is able o translate the whishes and dermands of a client to a concept and
developing this with tearm effort to a concrete technical solution,

EDF version
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4 MODIFYING EXISTING PAGE TEMPLATES AND
CHANGING PAGES
At an existing page template changes can be made. These changes however, won’t automatically

be applied to the pages that are based on that template. This can be done manually through the
[More settings] button and the [Pages] tab.

4.1 Changing a page template

Suppose it should be possible to add multiple paragraphs to the page template ‘Vacancy page’
and that a page section ‘Contact data’ must appear. The page section ‘Contact data’ is already
made and connected to a label and a page part.

4.1.1 Allowing ‘Additional elements’
= Select the [ Page templates ] tab and choose the desired template. In our example it
willbethe6 Vacancyo6page

= Tick the ‘Additional elements allowed’ box:

D Yacancy page =

Mame: Yacancy page

v Iz published
[ Available in Media Repository
Is—'[:sdditional elements allowed

Roles for this template
Editars [ Delete
Add & role: | = Select role hd

More settings

[ | | |
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= At the back text and content elements can now be added under the page template (in
this example a paragraph was added):

Software architect

Paragraph: GX Offers H

Title:

Lirk code:

Solutions that can only be conceived and realised by teams that are capable of contributing innovative
ideas, new perspectives and customer focus,

Image: <GX> i
Alternative text: Position:

[ Use a5 caption

Lirk code:

Paragraph: Software architect [ I

Title: |Soﬂware architect

Lirk code: |N0ne v

40 hoursAwveek
Location: Mijmegen

ou're an excellent technician and a creative, initiative and decisive architect with a big analytic
ability wham, by being a good listener and communicator is sble 1o Tanslate the whishes and
demands of a client to a concept and developing this with team effort to a concrete technical
solution,

Paragraph i=- =

Title: |

Lirk code: |N0ne v

ou play a vital role in setting up a program of dermands, the design, the development and the

wrmimtaimakilibg F o randinea meninet Ae o eradnet Sed Antiea i secceted Yooem berinn Han eekenie -l
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4.1.2 Adding a page section with ‘More settings’
= Click on the [More settings ] button.

= Go to the [Settings ] tab.

= Select the desired page section (here: ‘Contact data’) and save this change:

Varancy page .

= Select .
@] ®

= Select
= Select
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4.2 Passing on template changes to existing pages

Once the changes in this page template are done, these modifications can be implemented in
those pages that have been created, based on this template.

= Go to the [Page templates ] tab and choose the desired template. In our example
this is the ‘Vacancy page’.

= Click the [More settings] button. And go to [Pages] tab.

= Click the link ‘Show all pages with this template’. An overview will appear with the
page(s) that are based on this template.

= Tick at ‘Pages with this template’ the pages on which the changes need to be passed
onto.

= Tick at ‘Process changes’ the topics that have been changed and need to be
implemented (in this example it is allowed to add ‘New elements’ and a page section
‘Block’ has been added):

Maintain - Page templates

¥ Select a page template | Yacancy page v

Pages Settings

Fages with  Page title Change
this termplate Software architect (Wot suiisfhed) |
Technical author (Mot sublisted) ]
Mew page (hiot sutilisfied) ]
Software architect
[ Select all ] [ Select none

Show overview of this page template
Process MNew elements:

changes Removed elements:
Crder of elements:
Editability:
Content of non-editable elements:
Basic settings:
Block:
Labels:
Meta keywords:

O 00O o000

Pass the characteristics of this template to the pages that use this template:

Process changes

Apply || Close

Note: Ticking ‘Copy the properties of this template to the pages that use this template’
results in the disconnection of these pages from the page template. The page template’s
properties now become the properties of the page.

[ | | | |
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= Click [Process ¢ hanges] . After confirmation the list ‘Commando execution’ shows
the changes that have been processed:

Maintain - Page templates

¥ Select a page template | Yacancy page M

Fages Settings

Pages with

this template

Frocess
changes

Command

execution

Page title Change
Software architect (Not pubiched? il
Technical author (ot putnlisfied) O
Mew page (ot putlisted? il
Software architect
[ Select all ] [ Select none

Show overview of this page termplate
Hew elements:

Removed elements:

Order of elements:

Editahility:

Content of non-editable elements:
Basic settings:

Block:

Labels:

Meta keywords:

O O0ood oood«

Pass the characteristics of this terplate to the pages that use this ternplate:

Process changes

Mew elements: Yes
Remaved elements: No
Order of elements: Mo

Editahility: No

Content of non-editable elements: No

HIAe]

Page title: Software architect

Adding new elements 0 elements added 1 sections.

pagemodel.action_thange_hlock: Changed

Apply | Close

= Close the window. The following alert will appear: ‘Functionality has been changed.
Should GX WebManager restart?’.

= Click ‘OK’. GX WebManager will restart.

After GX WebManager’s restart, the changes are passed onto the pages that are based on this
page template. In our example it is now possible to choose content elements from the insert
menu and also the page section will appear at the list of assigned page sections for the page:

Page sections for this page =

Title
Contact data

State
Current version

| |
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The end result might look like this:

<

Content

Homa * With canfiguration *

Banners

Page section
Ms Office imports
Hewsletters

Page templates
PDF Ganarator
Check spelling
Languags suitch
Media Repository
Ouverview

User interaction
Connactors

MyWeb

te maintenance kxlernal databases| Personalization | Design

Pags termplates * Softwars architact * Software architect

Software architect

Gx Offers

wiorking for G¥ means inwelusment with cutting-adge tschnology. And of
course, our awn product, GH WebManager, At G, we work tagether closely
to deliver the top guality web solutions and products that our customers
haue come to expact from us.

Solutions that can only be concelued and realised by tesms that are
capable of cantributing inmovative ideas, new perspectives and custarmer
focus.

< > Software architect

40 hours/wesak
Location: Hijmegan

You're an excellent technician and a creative, initiative and decisive
architact with a big analytic ability whor, by baing a geod listener and
cornmunicator is able to translate the whishes and dermands of a client to &
concept and developing this with team effort to a concrete technical
salution.

“ou play a uital role in setting up a program of demands, the design, the
developrent and the maintainability of 2 medium project or product and
getting it accepted. You're baring the technical respansibility far the whele
irmplernentalr raute of the mediom size ar bigger prajacts. You report ta
the solution manager &.q. a3 project manager far web solutions and ta the
product manager for praducts, You guide software enginsers,

ontact data

Questions? Or do you like some
rmore information?

Con't hesitate to send an e-mail
to Iris van Dirteren via
talent@aq:.nl or call her on

+31 [0)24 - 282 22 &1,

PDF version

<GX> CREATIVE ONLINE DEVELOPMENT B.V.

e-mail info@gx.nl | http://www.gx.nl/ ‘ 24/24 ‘




